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ControlMaster DX™

Autofire2000 Programming, Monitoring and
Analysis Software

Program & monitor up to 8 kilns from one PC
Real-time graphs for Time vs. Temperature
Remote temperature readings

Data log and file export

Data analysis

Print Graphs
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Package Contents

) RS232 Chip
) Serial Cable
) Remote Programming and Monitoring diskette
)

(1
(1
(1
(2) Data Analysis diskettes

Hardware Installation

Each controller requires one RS232 serial port at the computer.

1. Connect the RS232 cable between the Computer serial port and the controller.
Kiln manufactures may provide a pre-installed port at the controller for this
connection. If no port is available, the supplied cable can be used to connect directly
to the controller electronics. See diagram 1 for connection location. (J1)

2. ControlMaster software requires the installation of a RS232 communications chip
on the controller electronics. See diagram 1 for installation location. The IC chip must
be installed in the proper direction with the notch (pin 1) towards the center of the
board.
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Diagram 1

Computer Requirements

ControlMaster is a Windows-based software program. It is compatible with any
industry standard, IBM-compatible personal computer and Microsoft Windows 95 or
higher. 800 x 600 monitor resolution is recommended.
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Software Installation

To Install ControlMaster DX™ Software on Windows95, Windows98 or
Windows2000:

Insert the floppy disk into a 3.5 disk drive.

Click Windows “Start”

Select “Run”

Open a:\setup.exe and click “OK” (substitute the appropriate letter for a: if your
floppy drive is not the a: drive)

Follow the on-screen instructions

PO~
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Controller Configuration

Node Id

The Node Id is a controller identification number. If there is only one AutoFire™
Controller attached to the computer, the Node Id may be set to any value from 0 -15.
The factory default value is 0. 0 is recommended for a single controller network. If
there is more than one controller connected to the computer, the Node Id should be
set to a different values for each controller for unique file name assignments and for
identifying the controller/kiln. The Node Id can be set from the controller keypad
Options or the software configuration screen.

Software Options

Two programs are supplied with ControlMaster DX.

1. Programming and Monitoring
2. Analysis

The Analysis application is optional. It is not required to run the Remote
Programming and Monitoring application.

ControlMaster™ 2.x allows you to program, monitor, and save firings from multiple
Controllers. The Analysis program allows you to graph, compare and print data from
the saved files.
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Programming & Monitoring Software

. Installation Information

ControlMaster™ is installed into the Windows ‘Program Files’ folder, in addition to
the ‘CMaster’ application file, two file folders are created.

Time and Temperature firing data is automatically stored in the ‘Datalogs’ folder
when a firing is started. The file name identifies when the file was created and for
which controller.

For example: CM NO1 2001_09_13 07_57_13 COM.LOG

ControlMaster [CM],

Controller Id #1 [NO1],

Date [Year_Month_Day] and
Time [Hour_ Minutes_Seconds].

Setup Information for programming the controller can be saved in the ‘Programs’
folder.
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Establishing Communications

Before the software can be utilized, it must detect and establish communications with
at least one controller. The program will scan all available ‘comports’ for a controller
connection. If no ports are found, the program will terminate. If you experience
trouble detecting a serial port, check the Windows Control Panel Device Manager for
active comports. As long as one port is found, the program will not terminate. Note
that the software will detect all comports, including modems, it does not matter if a
controller is connected to the port or not.

If the software does not terminate immediately, it has found available comports. If a
controller is connected to COM1, the software will automatically detect and display
the information for this controller. If the controller is not connected to COM1, the
software will wait to establish communications on this port. Click the Select option on
the menu bar to locate a controller on another comport.

ESelect Controller ;Iilil

The serial COM portz awailable to Control Master are zhown below. Select
the COM port that you wish to wiew on the main screen.

Green indicates that th . iz currently communicating with the con
Red indic: I the PC has NOT communicated with th Caontralkda zharted.
Tellow indicates that the PC has MOT communicated with the controller for an extended period of time.

Contrallar
Made [0 Contraller Description

‘] Iy _ Communication with controller has not been establizhed.

comMa _ Communication with controller has not been establizshed.

Ok I Cancel Edit Descriptions |
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Kiln Identification

Each controller can have unique controller identification from the Select screen. To
edit the Controller Description, click on the edit button at the bottom of the screen.
The edit feature is linked to the controller [d number not the comport assignment.

Modifyving the CMaster.INI file

The Select menu will display all known comports. Any comport can be excluded from
the software auto detection by editing the CMASTER.INI file. This is convenient for
excluding known modem ports from the software. If a modem port appears in the
menu selections, the INI file can be changed to ‘EXCLUDE’ this port from the
software. Below is an example of the CMASTER.INI with COM3 excluded. It is
important to use all capital letters when changing text in the INI file.

[Directories]

Programs=C:\Program Files\Control Master\Programs
Datalogs=C:\Program Files\Control Master\Datalogs
[COM_PORTS]

COM1=AUTO_DETECT

COM2=AUTO DETECT

COM3=EXCLUDE

COM4=AUTO_DETECT

COMS5=AUTO_DETECT

COM6=AUTO DETECT

COM7=AUTO DETECT

COM8&=AUTO_DETECT

COM9=AUTO DETECT
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Overview

ControlMaster™ is shown below. Programming options are similar to those
available on the controller keypad.
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= Programming selections are at the top-left part of screen.

= Program segments are entered (for User Programs) or displayed (for Cone
Firings) in the middle of the screen.

= Control buttons are located in the top-right corner.

= Alarm settings are located at the bottom of the screen.

= Monitoring information and controller status is in the left column.

= The status bar box on the far bottom-right indicates the number of times
information has been retrieved from the selected controller; it is an indication to
the operator that the PC is communicating with the controller

= The status bar box second from the right indicates the number of communication
errors that have occurred for the selected controller.
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Graph Option

Click the Graph option on the menu bar to display a graph of the selected program.
Graphs are also available to track the actual firing in process.

While viewing a graph, you can zoom in on the graph by left-click and dragging the
mouse to create a box around the portion of the graph you wish to view close up. To
return to the original graph, right click and select ‘undo’.
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Saving Setup Programs

Each time a firing is set up, the information for the firing can be saved as a Program.
This can save time by allowing the saved file to be re-opened with the retained set-
up information. To save a program, click on the disk icon at the top-left of the screen
and assign a user filename for the program. Programs can be retrieved by clicking
on the ‘open folder’ icon.

Programming Heating/Cooling Rates

When setting up a User ‘Ramp/hold’ program, cooling rates are programmed as
negative value and heating rates are programmed as positive values. Always use a
(-) sign when entering cooling rates.
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Configuration Screen

Click the Config option on the menu bar to view and edit controller configuration
settings.

E Controller Configuration

EN-

Configuration Settings can alter the performance and functionality of the controller.
Changes to the controller configuration should not be made without first reviewing
the controller user manual for detailed descriptions of configuration settings.
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Analysis Software

Installation Information

Analysis files will be saved in a separate Data folder.
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Importing files for Analysis

Click on the File menu and select ‘import Controller File'. A standard Windows ‘File
Open’ screen appears. Find the file to import from the ControlMaster Datalogs folder
and click 'Open' to proceed. Imported files can be renamed for analysis. After the
progress indicator reaches 100% the newly created analysis file appears in the file
directory at the bottom-left of the screen.
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To Display Data

First select the files you want by double-clicking on the file names in the directory list.
You can also navigate the directory list with the up-down keyboard keys or scrollbar.
File selections appear in the 'Selections' field at the bottom-center of the screen.

As many as 6 files can be displayed at one time.

Click the 'Draw' button to graph the file selections.

To remove a file(s) from the 'Selections' box, Double-click the file name in the

'Selections' box. To remove all files, click the 'Clear' button. This also erases the
graph window.
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View Options

Click on the View menu to change the type of data displayed in the graph. A screen
appears with 5 selectable curves to plot simultaneously. Check only the data you are
interested in viewing.

o Controller set-point temperature

e Top thermocouple temperature

o Middle thermocouple temperature
e Bottom thermocouple temperature

e Firing program profile.

EﬂData Types and Graphing Options __f il

Check boxes below to display
selected data.

[T Top Themocouple

[+ Middle Thermocaouple
[~ Bottom Thermocouple
[~ Program Prafile

—Enter Temperature Limitz and check Box to uze
HIGH temp o192

LW temp

[+ futo Scaling OFF a2

Enter Time Limits and check Box to use

LOW tire HIGH time

1] 500

v &uta Scaling OFF

The X and Y axis of the graph will automatically scale to fit the data. These limits can
be adjusted to ‘zoom’ on the data. The two fields for Time and Temperature allow the
operator to manual change the scale limits on the graph. Leaving these items
unchecked, the program automatically chooses the scale limits that are graphed.
Otherwise, the operator can type in limits.
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Temperature Units

Click the Units menu to change the temperature scale from Degrees Celsius to
Degrees Fahrenheit.

Graph Colors

Click the Colors menu to assign a color to any particular curve. A screen appears
with boxes showing the colors currently used for 6 possible files. The labels 'File #1 -
File #6 are the 6 files listed in the 'Selections' box from top to bottom.

The color box is shown '3D'". To select a box, click on it or Tab to the one you want.

To change the color, click the Palette menu or right-click on the box you want. A
standard Windows color pallete screen appears. Select a new color or cancel.

BPlutting Colors |

Pallete

Set Tol kdid B ot Program

=

File #1

File #2

File #3

File #4

File #5

File #E
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Adding Memos to a File

Click the Edit menu to add notes to the data files. A screen appears with 2 boxes.
The lower box has the file names shown in the 'Selections' box. Click on a file name
or press 'Enter' to view the memo for the selected file. Any text added to this field will
be included in the file. The text added to the top memo field does not print along with
the graph.

F3™Memo Editor x|
=
Type Text Here
[~

Printing files

To print a graph, Click on the File menu and select Print Graph. Grid lines can be
added to the graph after the print function has been selected.
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